Back to overview
Degraded

API Endpoints Causing Intermitent Timeouts

Feb 16, 2026 at 11:42pm UTC
Affected services
Loyalty

Resolved
Feb 17, 2026 at 1:51pm UTC

UPDATE:
Between February 13th and February 16th, our monitoring systems reported some intermittent API endpoint degradation, which impacted performance and caused occasional timeouts. Our Engineering team actively applied mitigation protocols and identified a resolution. A permanent fix was implemented on February 16th at 7:06 PM CST. Since then, the affected API endpoints have remained stable and are performing consistently. This issue is resolved, and all services are operating normally.

Updated
Feb 17, 2026 at 3:43am UTC

UPDATE:
Platform is currently stable, yet still closely monitored to ensure all API end points are back to normal. Unless anything changes, next update will be made in 12 hours.

Updated
Feb 17, 2026 at 1:06am UTC

UPDATE:
A fix has been implemented and our Engineering team continues monitoring accordingly.

Created
Feb 16, 2026 at 11:42pm UTC

Loyalty Platform Services
Our Engineering team has been actively working on the stabilization of some of our API end points which have degraded performance causing intermittent timeout, generating multiple alerts during the last three days. The problem seems to be fully addressed and we are expecting a prompt normalization of the the system. This degradation does not affect all our customers and will be closely monitored until fully recovered.