Back to overview
Degraded

Reporting Dashboards Loyalty Platform Not Refreshed

Feb 16, 2026 at 11:03pm UTC
Affected services
Loyalty

Resolved
Feb 18, 2026 at 11:48pm UTC

FINAL UPDATE:
The root cause of the recent data latency was identified as a silent failure of a secondary database server, which disrupted the data flow to our warehouse starting on February 13. In collaboration with our Business Intelligence (BI) vendor, our Engineering team performed a series of system resynchronizations to restore data integrity.

As of Tuesday, February 17, all data flows and dashboards returned to normal operation. Following 24 hours of stable monitoring, we have confirmed full system health. This incident is now resolved.

Updated
Feb 18, 2026 at 12:56am UTC

UPDATE:
Investigation and remediation efforts for the reporting dashboards are ongoing. Our technical teams are actively engaged in stabilizing the data flow. We will keep this page updated until all reporting capabilities have been fully restored.

Updated
Feb 17, 2026 at 7:56pm UTC

Update:
Engineering team has been actively monitoring the reporting systems. Although there are increasing improvements the issue is still being actively worked on. Will continue providing updates until full resolution.

Updated
Feb 17, 2026 at 3:47am UTC

UPDATE:
No change in current state, next update will be provided once all reporting capabilities are back to normal.

Updated
Feb 17, 2026 at 1:11am UTC

UPDATE:
Based on initial analysis, our Engineering team is following up a path to solution. We will continue providing updates until full reporting has been re-established.

Created
Feb 16, 2026 at 11:03pm UTC

We are currently investigating an issue where some Reporting Dashboards from our Loyalty Platform have not accurately refreshed since February 13, 2026. Our engineering team is actively working on a solution to stabilize the reporting flow and systems.
We will continue providing updates until full resolution. Thanks for your patience and support.